SYMPTOMS

When I try entering my license key in the Patch My PC (PMPC) Cloud portal, I see the following:

Error

“Your license doesn’t match the specified SKU (Enterprise Plus, Enterprise Premium). Please use the correct license key.”

Error - Your license doesn't match the specified SKU (Enterprise Plus, Enterprise Premium). Please use the correct license key.
Error – Your license doesn't match the specified SKU (Enterprise Plus, Enterprise Premium). Please use the correct license key.

CAUSE

This message is caused if you are entering a Managed Services Provider (MSP) license key.

RESOLUTION

As detailed in Cloud Requirements, MSP license keys are not supported.