SYMPTOMS
I’ve successfully deployed an app using Intune Apps for Cloud (Intune Apps). However, when I look at its properties (by clicking on the deployment, pressing More Info, and expanding the Assignment Type), why does it show (Group not found) beside the assignment?
If I edit the deployment and click Assignments, I also see the Group not found. Please remove the assignment message.
CAUSE
This is because someone has deleted the group used for the assignment from Entra.
RESOLUTION
To resolve this issue:
- Recreate and reconfigure the relevant group in Entra.
- Edit the deployment in the portal.
- Delete the relevant assignment.
- Re-add the assignment by browsing to the recreated Entra group.
- Complete the deployment.
**Note**
Even though the group has been recreated in Entra with the same name, it will have a different Object Id so the original assignment has to be deleted and recreated to pick up the new group with the new Object Id.
See the [Edit a Deployment](../../cloud-deployments/manage-cloud-deployments/edit-a-cloud-deployment.md) process for more details.