Author Topic: Issue with publish full content of any update by Patch My PC (and also by SCUP)  (Read 1229 times)

Offline jiri.stransky

  • Newbie
  • *
  • Posts: 3
    • View Profile
Hi,
Could you please help me with issue in our test environment?
We have more than one environments, and in real testing, without any restriction all work like charm, but on that with FW restrictions (which I unfortunately cant manage) is probably timestamp blocked.
I'm getting this error in patchmypc.log:
An error occurred while publishing an update to WSUS: Failed to sign package; error was: 2149122449

Unauthorized (401).

Source: Windows

And if I cleanup address for timestamp, I'm getting this error in patchmypc.log:
An error occurred while publishing an update to WSUS: Failed to sign package; error was: 2147942487

The parameter is incorrect.

Source: Windows

I mentioned SCUP as there is option for turn off timestamp and I had same issue since I didn't turn off the timestamping.

So, my questions are: Is there any option for turn off timestamp in PMPC? Or am I absolutely wrong, and error is connected with anything else?

Thank you
Jiri S.

Offline Justin Chalfant

  • Patch My PC Support
  • Administrator
  • Hero Member
  • *****
  • Posts: 2075
    • View Profile
    • Patch My PC Support
Can you let me know if this KB helps. Timestamping is a little tricky when a proxy is in use sometimes you may need to make a SYSTEM level proxy change

https://patchmypc.com/forum/index.php?topic=2673.0

Hi,
Could you please help me with issue in our test environment?
We have more than one environments, and in real testing, without any restriction all work like charm, but on that with FW restrictions (which I unfortunately cant manage) is probably timestamp blocked.
I'm getting this error in patchmypc.log:
An error occurred while publishing an update to WSUS: Failed to sign package; error was: 2149122449

Unauthorized (401).

Source: Windows

And if I cleanup address for timestamp, I'm getting this error in patchmypc.log:
An error occurred while publishing an update to WSUS: Failed to sign package; error was: 2147942487

The parameter is incorrect.

Source: Windows

I mentioned SCUP as there is option for turn off timestamp and I had same issue since I didn't turn off the timestamping.

So, my questions are: Is there any option for turn off timestamp in PMPC? Or am I absolutely wrong, and error is connected with anything else?

Thank you
Jiri S.

Offline jiri.stransky

  • Newbie
  • *
  • Posts: 3
    • View Profile
Hi,
I'll try this solution and let you know. I read the post, but as there is no mentioned precisely this error code I didn't try it.
Thank you

Jiri S.

Offline Justin Chalfant

  • Patch My PC Support
  • Administrator
  • Hero Member
  • *****
  • Posts: 2075
    • View Profile
    • Patch My PC Support
The returned error code and change depending on how the proxy may respond.

Offline jiri.stransky

  • Newbie
  • *
  • Posts: 3
    • View Profile
Proposed solution works well :). Thank you Jiri S.