• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

7-zip, Mediamonkey 5 and PicPick are still shown as outdated

Started by Peter_K, January 21, 2022, 11:45:34 AM

Previous topic - Next topic


7-zip, Mediamonkey 5 and PicPick are still shown as outdated, while they are actually updated.

This list began with 7-Zip, later joined by Mediamonkey 5 and PicPick.

See also attached screengrab.

7-Zip is not being updated anymore although is still shows red. Hence the line below states "Perform 2 Updates."

Omar (Patch My PC)

This means there are older versions of these apps installed with the latest ones!
The red list already tells you about 7-zip v19.0 and PicPick 5.2.0 installed, if you removed them and only kept the latest all will be good!!
The same with MediaMonkey but I'm not sure about the exact version


For 7-Zip there were indeed two installations, and now that is solved.

For Mediamonkey 5 and PicPick I only see one installation.

Attached new screengrab.

Omar (Patch My PC)

There could still be some leftovers of previous versions of these apps, click on the "Uninstaller" on the left tab and see if there are older versions of them in that list, if you found them then select them then select "Delete" not "Uninstall"


Nope, only one installed each.

I already uninstalled the old version of 7-zip that way.

Yesterday I completely uninstalled PicPick, and then installed it again. But with no change.

Could it be there are actually remnants of newer versions installed?

When I reinstalled PicPick via PatchMyPC I got a message that a newer version is available.

Mediamonkey auto-updates as well.


I had the same problem with PicPick, see screenshot.  I have no idea if it will stay fixed. After PatchMyPC installed version 5.2.1 I searched the registry for 5.2.0 and changed it to 5.2.1. Now it is not being reinstalled each time PatchMyPC is run.

Omar (Patch My PC)

Oh I just realized that the URL is actually downloads v5.2.0 although the website says the latest is v5.2.1 !
So I checked the website for a new URL and I actually found a new one specifically for v5.2.1 !
So we just fixed this :) Sorry about that!

As for MediaMonkey we didn't find any problems with our testing !


Another one solved, thank you very much!

Are you sure MediaMonkey doesn't have the same problem? The latest version is

Omar (Patch My PC)

You are welcome!

Yeah we are using the URL of this version for MediaMonkey, but it only registers as version "5" in the registry or in Add/Remove Programs !
And they actually need to fix this and add at least 5.0.2 in the registry because only "5" causes problems and won't let Patch My PC to detect all the minor updates!!
This might be your issue, but it still works fine with us!... So are you sure that you don't have any older MediaMonkey installed?


Yes, I am sure I have no older version installed.

So, perhaps this is a problem caused by MediaMonkey then?

Omar (Patch My PC)

Can you run Patch My PC now and let me know if it's fixed?

Omar (Patch My PC)

You are welcome!
This is still MediaMonkey's developers fault though! They are only using "5" in the version ! I used that before in PMPC and it didn't work with some users and when I changed it to 5.0 it worked !
But that 5.0 didn't work with you and when I changed back to just 5 it worked again! Both worked for us in here so it doesn't matter for now..
The version is 5.0.2 then it should be 5.0.2 in registry not just 5 😕
And when it's 5.0.3 , 5.0.4 etc. it will still be just 5 in registry! Then PMPC won't detect it for future updates! We will use the new URL though.
I think when 5.1 releases they will update it to 5.1 ... but the same story with 5.1.0, 5.1.1, 5.1.2 etc 🤷🏻‍♂️