Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - NODeeJay

Pages: [1]
1
Software Request - Currently Incompatible / OpenVPN community package
« on: October 11, 2016, 02:57:02 AM »
Hi there,

I would appreciate the OpenVPN installers for Vista and above in 32-bit and 64-bit (https://openvpn.net/index.php/open-source/downloads.html).

It's mostly straight forward with the following command line parameters:
Code: [Select]
/SELECT_SHORTCUTS=1 /SELECT_OPENVPN=1 /SELECT_SERVICE=1 /SELECT_TAP=1 /SELECT_OPENVPNGUI=1 /SELECT_ASSOCIATIONS=1 /SELECT_OPENSSL_UTILITIES=0 /SELECT_EASYRSA=0 /SELECT_PATH=1 /SELECT_OPENSSLDLLS=1 /SELECT_LZODLLS=1 /SELECT_PKCS11DLLS=1 /S
Is installed rule: Compare HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\OpenVPN
DisplayVersion EqualTo 2.3.xx-Ixxx (DisplayVersion EqualTo 2.3.12-I602)

Is installeable rule: Windows Version GreaterThanOrEqualTo 6.0.Workstation
RegKeyExists: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\OpenVPN

A know issue is that the update won't finish if OpenVPN is running as a started service. User interaction is needed as the TAP driver may come up asking for permission.

Thanks,

Alex

Pages: [1]