• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

rsItemNotFound Error when Trying to Drill Down in PatchMyPC Reports

Started by EntrustDatacard, December 05, 2016, 01:02:46 PM

Previous topic - Next topic


I installed the PatchMyPC reports a few months ago when we purchased the product. Then I did a huge SCCM upgrade\SCUP re-install and re-installed the PatchMyPC reports again. I'm pretty sure its all installed correctly. When I click on any report it loads correctly no errors or issues. I'm not sure the percentages are correct but I haven't had time to double check yet. Problem is when I click on example the 01- Compliance Dashboard for Third-Party Updates report or any PatchMyPC report then I click on any link or try to drill down at all such as graphs, titles, etc i get the error "The item '/ConfigMgr_DCC/_Patc_ My_PC_Reports/08 - Third-Party Updates Date Range' cannot be found. (rsItemNotFound)". I get the same error using the web or SCCM console. I'm logged in using my admin creds which should have full admin access to everything but I did have rights issues re-setting up the normal SCCM reports after the SCCM upgrade. But I've since fixed that and the SCCM reports are working correctly. I need to be able to drill down to see more details from the PatchMyPC reports such as which apps\updates are missing from which workstations\servers. I've attached both the web and console errors. I'd appreciate any help.

If possible I could share a WebEx session and phone call to help me troubleshoot this issue.

Andy Konczak
Entrust Datacard
[email protected]
Work: 952-988-1624


I was able to fix my own issue so this issue can be ignored.

After searching the internet and forms for the last few hours I finally decided to simply re-install the PatchMyPC reports under a different name. It took about 3 min to do and now all the drill downs are working. I wish I would have tried that first  :)

To anyone out there having the same issue try the reports re-install first.



I will also note I did mess with the report service rights etc. But the old reports still didn't work.

Justin Chalfant (Patch My PC)