Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - grmorgan618

Pages: [1]
1
Any update on enabling the ability to use PatchMyPC to fresh deploy an app over just patching what installed?

Could the update detections include an additional registry value like [HKLM\Software\PatchMyPC] .. AdobeReaderDC19=dword:1  that would allow me to sign up for the install?
I would think this value would also have to be wiped out with the install just to make sure it didn't keep pushing when product was removed at some point later.

Anyway, I know there's a downside to this specifically but just sharing in case it sparks an idea
I was curious if this is actually in the roadmap and if so how far out?

Thanks!

2
Looks like there is a new version of PDFCreator available -- we've been getting the error for around or just over a week.

PDFCreator 3.2.0   1/17/2019 9:41:45 AM   32.03MB   Updates   Moderate   
Digest of the downloaded update doesn't match the digest from the catalog: [VF5KMrtWpOefNUnSmfi8mwN6ENU=] vs [pa0ZJCSs6LvDE2fdPAgq9qNwbaM=]



3
Archived Feature and Product Request / Enhancement: Pre/Post Scripts
« on: January 17, 2019, 07:38:45 AM »
I haven't had any time to look at the pre/post scripts yet so I had some questions... and if the answers are no, then emerges my enhancement requests....

1 - am I able to fail the patch from the pre-script? ... for instances,  if my pre-script returns a greater than 0 return code does the patch fail?
* my goal is to put logic in my pre script so I skip(fail) updates until the deadline, then kill processes but I want my pre-script to handle it - not be static like the publishing options are.

2 - is any information about the currently running update (product and version) passed to the pre/post scripts as arguments?
* my goal is to make a single dynamic pre/post script based on the product and when needed the version. in simple usage, a single script for all products that utilized a switch/case function (or ... :) since I see PatchMyPC is written in Vb.net Select/Case ...)


4
Oracle Virtual Box needs to stop upgrading v5 to v6 ... and have two separate updates for each path ...

V5.2 and v6 should be two different upgrades and introduce a migration entry to go from one to the other.

What's specifically affecting us - "Please also use version 5.2 if you still need support for 32-bit hosts, as this has been discontinued in 6.0. Version 5.2 will remain supported until July 2020. " -- https://www.virtualbox.org/wiki/Downloads

Thanks!

5
I have Node.js 10.12 LTS x64 installed. Both 10.14 LTS and Node.js 11.3.0 are being installed.

Install i tested with -
https://nodejs.org/download/release/v10.12.0/node-v10.12.0-x64.msi


6
Could you all double check the Adobe Acrobat and Acrobat reader classifications for the latest releases?

The Adobe Acrobat and Adobe Acrobat Reader classification for 19.8.20080 is "Security Update" in PatchMyPC Catalog but the APSB18-30 security bulletin lists 19.8.20071 (https://helpx.adobe.com/security/products/acrobat/apsb18-30.html) .. the 19.8.20080 release notes list this as a hotfix patch ... https://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotesDC/continuous/dccontinuousoctober2018qfe2.html#dccontinuousoctobertwentyeighteenqfetwo

With your new use of classifications, this could cause this non-security version to download/deploy.

Thanks! (BTW, let me know if reporting stuff like this should go to another forum).

7
I was approached the other day regarding the use of your catalog with a security question, since the person asking is my director - i sort of need to provide an answer :)

How does Patch My PC ensure that the content you distribute has not been compromised?
Is the hash of the binary downloaded from the vendor verified before the package is created and made available OR does the publishing service download the files directly from the vendor during acquisition?

The concern is around virus or malware making it into your process and then distribute it under our code signing cert to our endpoints.

In your response, please any links you have to virus scaning, hash validation, etc that is part of your creation and distribution process prior to enabling customer consumption of a patch.

Thanks!

8
Brand new Patch my PC user (with SCCM 1802) here... We just got the publishing app installed and configured. We are syncing all metadata in order to understand what we have in our environment that needs patching.  My question is I'm seeing products that look like they should be superseded showing up as not... A couple examples ... DisplayLink 8.6 M0 and M1, Audacity 2.2.2 and 2.3.0, Citrix Receiver 4.9 and 4.12, Dropbox 57.4.89 and 58.4.92, FileZilla Client 3.37.1, 3.37.3 and 3.37.4, Foxit Reader 9.2.0.9297 and 9.3.0.10826 ....  should/does the metadata-only sync include supersedence information? Thanks ahead of time!




Pages: [1]