Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - grmorgan618

Pages: [1] 2
1
 :)  nice

Thanks Justin!

2
Any update on enabling the ability to use PatchMyPC to fresh deploy an app over just patching what installed?

Could the update detections include an additional registry value like [HKLM\Software\PatchMyPC] .. AdobeReaderDC19=dword:1  that would allow me to sign up for the install?
I would think this value would also have to be wiped out with the install just to make sure it didn't keep pushing when product was removed at some point later.

Anyway, I know there's a downside to this specifically but just sharing in case it sparks an idea
I was curious if this is actually in the roadmap and if so how far out?

Thanks!

3
Archived Feature and Product Request / Re: Enhancement: Pre/Post Scripts
« on: January 21, 2019, 01:15:15 PM »
Awesome - yup that will work for me.

4
As always, you guys rock thank you for the quick response

5
Good call - thanks for the info.
It's blocked :)

6
Archived Feature and Product Request / Re: Enhancement: Pre/Post Scripts
« on: January 17, 2019, 10:05:11 AM »
Awesome - this would really enable me to do some cool integration with the updates.. Especially if you allowed me to define the parameters :)
"Parameters to pass to ScriptRunner"... then allow me to define them from all the fields
%ProductName% %ProductVersion% %CVENumber% 

In the mean time, I'll work through tracing the parent processes and seeing what type of information i can pull out of those to help feed this.

Thanks Again!

7
Archived Feature and Product Request / Re: Enhancement: Pre/Post Scripts
« on: January 17, 2019, 09:57:33 AM »
Thanks for the answers Justin -- appreciate the quick responses!

For question 2, ... if I have a pre-script and post-script set... does that script get passed any parameters from scriptrunner?
My question/request is more that
ScriptRunner would call my script like this
Script.ps1 "Adobe Reader" "37.0.1"

8
Looks like there is a new version of PDFCreator available -- we've been getting the error for around or just over a week.

PDFCreator 3.2.0   1/17/2019 9:41:45 AM   32.03MB   Updates   Moderate   
Digest of the downloaded update doesn't match the digest from the catalog: [VF5KMrtWpOefNUnSmfi8mwN6ENU=] vs [pa0ZJCSs6LvDE2fdPAgq9qNwbaM=]



9
Archived Feature and Product Request / Enhancement: Pre/Post Scripts
« on: January 17, 2019, 07:38:45 AM »
I haven't had any time to look at the pre/post scripts yet so I had some questions... and if the answers are no, then emerges my enhancement requests....

1 - am I able to fail the patch from the pre-script? ... for instances,  if my pre-script returns a greater than 0 return code does the patch fail?
* my goal is to put logic in my pre script so I skip(fail) updates until the deadline, then kill processes but I want my pre-script to handle it - not be static like the publishing options are.

2 - is any information about the currently running update (product and version) passed to the pre/post scripts as arguments?
* my goal is to make a single dynamic pre/post script based on the product and when needed the version. in simple usage, a single script for all products that utilized a switch/case function (or ... :) since I see PatchMyPC is written in Vb.net Select/Case ...)


10
Oracle Virtual Box needs to stop upgrading v5 to v6 ... and have two separate updates for each path ...

V5.2 and v6 should be two different upgrades and introduce a migration entry to go from one to the other.

What's specifically affecting us - "Please also use version 5.2 if you still need support for 32-bit hosts, as this has been discontinued in 6.0. Version 5.2 will remain supported until July 2020. " -- https://www.virtualbox.org/wiki/Downloads

Thanks!

11
Justin - thank you, the update you made works perfectly.

13
Yeah whatever you can do to not have it upgrade major versions  thanks

14
Yes that would help... This is messing up some of our Dev environments

15
I have Node.js 10.12 LTS x64 installed. Both 10.14 LTS and Node.js 11.3.0 are being installed.

Install i tested with -
https://nodejs.org/download/release/v10.12.0/node-v10.12.0-x64.msi


Pages: [1] 2