Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Andrew Jimenez

Pages: [1] 2 3 4 5 6 ... 9
1
You should not need the console for that specific task, and the feature is in production.

2
Confirmed. I'll update the website shortly with this information. I have also added the appropriate processes to the application so that you can use our "Manage Conflicting Processes" feature to close the app prior to update. https://patchmypc.com/manage-conflicting-processes-when-updating-third-party-applications

3
Hi Aleksander,

I believe this application needs to be closed before installation will complete successfully. I am still testing this and will confirm and add it to our known issues page once I confirm the issue. https://patchmypc.com/known-issues-and-considerations-when-using-patch-my-pc#topic2

4
Hi Aleksander,

Sorry for the delay on this! I'm not sure how we missed it, but we are looking into it now.

5
The SCUP schema is the same as is used in ConfigMgr. The creator of WSUS Package Publisher actually works for us :) I'll have him check this out.

6
Interesting. What is the full title of that update?

7
Hello,

I believe our Non-LTSR updates (starting with 21.7.0.44) Are already doing what you are suggesting:

Code: [Select]
<lar:And>
<bar:RegValueExists Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\CitrixOnlinePluginPackWeb" Key="HKEY_LOCAL_MACHINE" Value="DisplayVersion" RegType32="true" />
<bar:RegSz Comparison="Contains" Data="Workspace" Value="DisplayName" Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\CitrixOnlinePluginPackWeb" RegType32="true" />
<bar:RegSzToVersion Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\CitrixOnlinePluginPackWeb" Value="DisplayVersion" Comparison="LessThan" Data="21.7.0.44" Key="HKEY_LOCAL_MACHINE" RegType32="true" />
<bar:WindowsVersion Comparison="GreaterThan" MajorVersion="6" MinorVersion="1" ProductType="1" />
<lar:Not>
<lar:Or>
<lar:And>
<bar:RegValueExists Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Citrix\ICA Client\AutoUpdate\Commandline Policy" Value="LTSROnly" RegType32="true" />
<bar:RegSz Comparison="EqualTo" Data="true" Value="LTSROnly" Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Citrix\ICA Client\AutoUpdate\Commandline Policy" RegType32="true" />
</lar:And>
<lar:And>
<bar:RegValueExists Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Policies\Citrix\ICA Client\AutoUpdate" Value="LTSROnly" RegType32="true" />
<bar:RegSz Comparison="EqualTo" Data="true" Value="LTSROnly" Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Policies\Citrix\ICA Client\AutoUpdate" RegType32="true" />
</lar:And>
</lar:Or>
</lar:Not>
</lar:And>

Currently, for NON-LTSR to be applicable the following conditions must be met:
Registry key "CitrixOnlinePluginPackWeb\DisplayVersion" exists and is less than 21.7.0.44
Registry key "CitrixOnlinePluginPackWeb\DisplayName" exists and contains "Workspace"
Windows Version > 6.1
NOT
(OR
   (Registry key Commandline Policy\LTSROnly exists AND = true)
   (Registry key AutoUpdate\LTSROnly exists and  =true)
)

I went ahead and made truth table for the second part to make sure the logic was sound.
X = ! ( ( a && b ) || ( c && d ) )
Cmdln exists (a)Cmdln eq True (b)AutoUpdate exists (c)AutoUpdate eq true (d)Applicable (X)
00001
00101
00110
10001
10101
10110
11000
11100
11110

Looking at this, the only times the NON-LTSR update would be applicable are:
  • no registry keys are set
  • AutoUpdate\LTSROnly exists and is set to false
  • CommandLine Policy\LTSROnly exists and is set to false
  • CommandLine Policy\LTSROnly and AutoUpdate\LTSROnly both exists and both are set to false

Otherwise, the LTSR version is applicable (either the install flag was set or the GPO is set).

From what I understand from your explanation, I believe this is the behavior you are looking to have for this application. Please let me know if I am misunderstanding.

8
Hi Jared,

I do wonder if this is an issue with the VSCode installer itself. There is a long-standing issue on the github that sounds exactly like this problem: https://github.com/microsoft/vscode/issues/47841

9
A fix just rolled out in today's catalog update, we had to fall back to a file version detection if the registry version detection does not work. This seems to have been a problem since they switched over to the MSI based installer. We modified the existing updateid, so you will want to republish https://patchmypc.com/when-and-how-to-republish-third-party-updates the Nextcloud update to make this change active, otherwise all future releases should be fixed as well.

10
We were able to replicate this and will work to resolve this week.

11
Thanks for the report, we will see if we can replicate and fix this issue.

12
This should be updated in today's catalog release. Please reach out if you still run into issues!

13
Interesting, I think we'll need to collect logs for this can you please open a support case here: https://patchmypc.com/technical-support
Please include the following logs from a device where the software is not showing as applicable:
%WinDir%\CCM\Logs\CAS*.log
%WinDir%\CCM\Logs\DeltaDownload*.log
%WinDir%\CCM\Logs\DataTransferService*.log
%WinDir%\CCM\Logs\PatchMyPC-ScriptRunner.log (If exist)
%WinDir%\CCM\Logs\ScanAgent*.log
%WinDir%\CCM\Logs\StateMessage.log
%WinDir%\CCM\Logs\UpdatesDeployment*.log
%WinDir%\CCM\Logs\UpdatesHandler*.log
%WinDir%\CCM\Logs\UpdatesStore*.log
%WinDir%\CCM\Logs\WUAHandler*.log
%WinDir%\WindowsUpdate.log
You need to run Get-WindowsUpdateLog on Windows 8.1 and newer in PowerShell.

Thanks!

14
What version of Notepad++ are you currently running? I just checked on my test box and it is 8.1.1 x64 is showing as applicable for me.

Here is the applicability rules for Notepad ++ 8.1.1 x64. If you can check that these registry values exist:
Code: [Select]
<lar:And>
  <bar:RegValueExists Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Notepad++" Value="DisplayVersion" />
  <bar:RegSzToVersion Comparison="LessThan" Data="8.1.1.0" Value="DisplayVersion" Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Notepad++" />
  <bar:WindowsVersion Comparison="GreaterThan" MajorVersion="5" MinorVersion="1" ServicePackMajor="3" />
</lar:And>

15
Hello,

Can you confirm the deployment method? WSUS/ConfigMgr App/Intune App?

Pages: [1] 2 3 4 5 6 ... 9