• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

Recent posts

Hey Wolfy
  You can use the Intune Application Manager to see all of your published PMPC Apps/Updates then check for assignments. https://patchmypc.com/intune-application-manager-utility  Feel free to schedule a review call with one us to go over this in more detail with you so you can show your clients.  https://patchmypc.com/environment-review-call
So, I'm running the PowerBI report used for showing, well, trying to show clients what is going on with their patching (we are an MSP with the MSP license). We are dogfooding using ourselves first.

I have everything configured, but when I run this report based on our Intune updates, I see a large number of Unassigned patches. Our intune device group here has all of our Windows PCs, and I have Intune updates set up (and am only using updates, including when I export the CSV for the report data). I'm unsure why patches aren't assigned, and any client would ask us "why the red number seems so high and what it means".

The only thing I can think of is that we retain the current update and one back for each product (in case of a need to go back one revision). Could it be that the report is reflecting the older revision of updates? Or is there something I need to do to ensure these are assigned? How do I clearly find what is assigned and what is not?
Quote from: Latino on June 07, 2024, 07:37:19 AMIt's incredible that this issue still hasn't been solved!
Maybe it has to do with the wrong link in PMPC to the webpage of XNView MP?
It should read https://www.xnview.com/en/xnviewmp/
and not https://www.xnview.com/en/xnview/ ("mp" is missing) as is presently indicated im PMPC.
Agree. I do not understand either why it takes so long to fix the issue. Hopefully it gets fixed without any further delay. Best of luck in fixing the issue.
It's incredible that this issue still hasn't been solved!
Maybe it has to do with the wrong link in PMPC to the webpage of XNView MP?
It should read https://www.xnview.com/en/xnviewmp/
and not https://www.xnview.com/en/xnview/ ("mp" is missing) as is presently indicated im PMPC.
Thank you for the suggestions! I will keep digging into the issue and I will update you if I find the root cause. These vendor supported machines frequently cause us issues, so they are definitely not our standard build.
Ah okay, but is there an option to reduce the updates ferquenzy ?
Hey Bardo,

Thank you for reaching out.

This seems to be bit tricky, because the " Waiting for another installtion to complete" can indeed be tricky to diagnose sometimes.
It may occur due to many reasons :

1. Maybe due to a pending  restart or stuck installation.
2. Service conflict.
3. Group Policy conflict
4. Task that might interfere.

Initial troubleshooting steps/ checks you can perform :

- Sometimes updates or installations require a restart to complete, and if this hasn't happened, it can block subsequent updates.
Found a script online to check the pending reboots : https://thesysadminchannel.com/remotely-check-pending-reboot-status-powershell/

- Ensure that no services related to Windows Update, MSI, or other relevant services are stuck or in a conflicting state.Restart the Windows Update and MSI Installer services.

- Since you've checked the CCM logs, it might be useful to look deeper into specific log files such as UpdatesHandler.log, CAS.log, and ExecMgr.log on the affected machines to find more details about what might be blocking the installation.

- Even though you've replaced local GPOs with correct domain policies, double-check for any residual effects or conflicts. Use the gpresult /h gpresult.html command to generate a report and ensure that the correct policies are being applied and there are no overriding local policies.

- Ensure there are no scheduled tasks that might interfere with the update process. Check the Task Scheduler for any tasks related to updates or MSI installers that might be stuck or repeatedly running.

- Try manually installing one of the updates that are stuck to see if it gives any specific error message or if it succeeds, which might provide more insight.

Hope this helps.

Hi there,

I am running PMPC version 4.5.04 on a Windows 10 Pro 22H2, build 19045.4412 machine.

I have updated to Zotero 6.0.36, however PMPC still showing update needed for Zotero 6.0.30.

We have some number of servers that are partially managed from a vendor that do not want to install software updates without manual assistance. This occurs for both updates that are sent using PatchMyPC through MECM and for Windows Updates sent through MECM, so I don't think this is a PatchMyPC specific issue. However, I'm hoping somebody might have ideas on how to resolve it. I suspect the vendor has done something to attempt to make it so updates don't install.

I did find several local GPOs that were intending to mess with WSUS settings, but those are successfully replaced by correct domain policy.

The symptom is that updates transfer to the endpoints, but they are eternally "waiting for another installation to complete." I've checked for either msiexec or Windows Installer running on the machines, but I don't see anything.

I've checked all the CCM logs and WSUS logs, but I have been unable to find anything meaningful.

Does anyone have any tricks to find out why the machines believe other installations are happening?


Thankyou for pointing this out, we'll revert this change - it was only supposed to be applied to the .MSI variants.

FYI they have stopped serving up the latest MSI packages on these URLs:


Those versions are now out of date (3.25.54065.37203) whereas the EXE version is 3.25.54307.37251:


According to this forum post, they are now expecting customers to get the latest MSIs from the portal:

However both the links posted there, as well as the URLs that the built-in auto updater grabs from the API, point to .zip files, which Patch My PC doesn't yet support extraction of, hence the requirement for the local content repo!