• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

Putty 0.78 Application package fails to install

Started by brandonm, December 15, 2022, 07:16:18 AM

Previous topic - Next topic


We are having a problem with the PMP Putty 0.78 package (SCCM). It is failing to install on all computers we have attempted, returning the same error code. The error code is 0x8000(32768). Do not believe we are having any problems with other PMP Application packages installed from the Software Center. As a test, I verified that the WinMerge package installs successfully.

This is a log from AppEnforce.log of one of the computers:

+++ Starting Install enforcement for App DT "PuTTY 0.78 (x64)" ApplicationDeliveryType - ScopeId_F8C75349-4CF6-4711-9C4A-97B6298C64CB/DeploymentType_98cf91a3-634e-4e8b-8c46-cedaf12309db, Revision - 4, ContentPath - C:\WINDOWS\ccmcache\1ec, Execution Context - System   AppEnforce   12/15/2022 9:04:45 AM   22020 (0x5604)
    Performing detection of app deployment type PuTTY 0.78 (x64)(ScopeId_F8C75349-4CF6-4711-9C4A-97B6298C64CB/DeploymentType_98cf91a3-634e-4e8b-8c46-cedaf12309db, revision 4) for user.   AppEnforce   12/15/2022 9:04:45 AM   22020 (0x5604)
+++ Application not discovered with script detection. [AppDT Id: ScopeId_F8C75349-4CF6-4711-9C4A-97B6298C64CB/DeploymentType_98cf91a3-634e-4e8b-8c46-cedaf12309db, Revision: 4]   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    App enforcement environment:
   Context: Machine
   Command line: PatchMyPC-ScriptRunner.exe /InstallPackage
   Allow user interaction: No
   UI mode: 1
   User token: not null
   Session Id: 1
   Content path: C:\WINDOWS\ccmcache\1ec
   Working directory:    AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Prepared working directory: C:\WINDOWS\ccmcache\1ec   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Prepared command line: "C:\WINDOWS\ccmcache\1ec\PatchMyPC-ScriptRunner.exe" /InstallPackage   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Executing Command line: "C:\WINDOWS\ccmcache\1ec\PatchMyPC-ScriptRunner.exe" /InstallPackage with user context   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Working directory C:\WINDOWS\ccmcache\1ec   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Post install behavior is BasedOnExitCode   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Waiting for process 16472 to finish.  Timeout = 120 minutes.   AppEnforce   12/15/2022 9:04:47 AM   22020 (0x5604)
    Process 16472 terminated with exitcode: 32768   AppEnforce   12/15/2022 9:04:49 AM   22020 (0x5604)
    Looking for exit code 32768 in exit codes table...   AppEnforce   12/15/2022 9:04:49 AM   22020 (0x5604)
    Unmatched exit code (32768) is considered an execution failure.   AppEnforce   12/15/2022 9:04:49 AM   22020 (0x5604)
++++++ App enforcement completed (3 seconds) for App DT "PuTTY 0.78 (x64)" [ScopeId_F8C75349-4CF6-4711-9C4A-97B6298C64CB/DeploymentType_98cf91a3-634e-4e8b-8c46-cedaf12309db], Revision: 4, User SID: S-1-5-21-xxxxxxxxx] ++++++   AppEnforce   12/15/2022 9:04:49 AM   22020 (0x5604)


Just want to add that I restored the Putty 0.77 version and that installs properly. I will leave that in place until the 0.78 package is fixed.


I'm seeing the EXACT same issue with PuTTY 0.78 in our environment.  Any update from PMPC on a solution?

C. Monroe




Looks like this is still an issue for us. Are others still seeing the Putty install failing?



you need to republish this application from the PatchMyPC publishing tool.  They added a .ps1 prescript that must be downloaded into your package.  if you look in the PatchMyPC-ScriptRunner.log on a client pc with the failure you will see this .ps1 script is not found.  they published a note on the putty pre-post script page shown in the attachment.


I have the pre script now but mine is still failing. I am on a machine that has never had Putty installed before. Is this fixed for anyone?


I also republished and have the pre-script now but mine is still failing. I am on a machine that has never had Putty installed before.

Adam Cook (Patch My PC)

If you're still experiencing issues with this, please send client logs to [email protected].



had the same issue - I've add manually that script
First, copy from the PMPC site, save it as "PatchMyPC-Remove-Application-PuTTY.ps1" and add to Putty by right clicking the app and selecting "Manage Custom Pre/Post Scripts" and select this script file and re-publish app.

IT's very important to give that specific name to this script as it will fail if you will name it differently.

Adam Cook (Patch My PC)

That is the correct procedure, yes. Or, you can delete the Application in-console, and the source folder, and re-sync to recreate it which should pull down the script into the package. This is a result of a bug in the Publisher that can't add Patch My PC Recommend or Defined scripts after the fact the product has been added to the catalogue.

This was fixed in However, unfortunately a republish doesn't work either so I've raised another bug report internally to fix this.


Thanks Adam. I deleted the Putty Application from CM console and deleted the source files from disk. Resynced PMP, deployed Putty, tested installation and it was successful.


I also verified that deleting the application and source content and republishing has fixed it for me as well. Thanks!