• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

Running a PMP Installer Package Manually

Started by Cob_WorkerBee, March 03, 2021, 11:02:24 AM

Previous topic - Next topic


Hello everyone!

New customer, first time poster.

We have some systems in our environment that aren't SCCM managed and are "Offline" (no internet access), but I have to update software on them occasionally. I know that it's possible to integrate PMP within an offline WSUS server, but this politically complicated in my situation.

I've been searching the FAQs/KBs/forums to see if someone has asked this question before but I can't find it, or find the right search terms.


  • Is it possible to copy the PMP package files from our repository and (as admin) locally run ".\arbitrarypackage\PatchMyPC-ScriptRunner.exe /InstallPackage" on one of these local systems to update the software?

Admittedly, I've already tried this, but it doesn't seem to do anything. I figure either there is a special switch to handle this situation, the PMP wrapper doesn't like being run in this way, or something else.

Does anyone know if/how I can run PMP app packages locally?


Cody Mathis (Patch My PC)


This will definitely work!

It will rely on the package.xml file being available, as well as the DLL Files which are packaged alongside scriptrunner.

We also recently made changes so that the default behavior of scriptrunner is /installpackage which means if you have all the files in place you can simply double click scriptrunner.

If you are unable to get this to work I encourage you to put in a support ticket with the below link with details.



Hello All,

I have the same scenario but am trying to test an install with the JAVA 8 package, at this time I am using the "Modify command line" feature with "/s INSTALLDIR=C:\Temp\jretest /L C:\Temp\javasetup.log" as my argument. I first pull all files out of .cab to a folder in my temp directory, and run "C:\Temp\WSUSContentPull\PatchMyPC-ScriptRunner.exe" (with and without /installpackage) but am not seeing anything being completed.

Note* package.xml does not exist until the first time I run script runner, I have made several attempts after that file was created.

Package.xml contents

<?xml version="1.0" encoding="UTF-8" standalone="true"?>








Due to the length of time it takes to move these files between online and offline WSUS, I want to see it work in our Online environment. 

Cody Mathis (Patch My PC)

Hello, WSUS does not use package.xml

All the parameters are passed as arguments directly to scriptrunner and /installpackage is not used.