• Welcome to Support Forum: Get Support for Patch My PC Products and Services.
 

Recent posts

#31
To reiterate, what we're seeing is after the deadline has been surpassed, the mechanism that is supposed to force close the running process is not working.  Confirmed on 2 end user's machines this morning.
Is there a setting I'm missing or do we just count this as a glitch with the ccm client?
#32
I have attached a ss of how all updates are set for conflicting processes.

As I was skimming through, I cannot believe I did not spot the drop-down for Focus Assist...  :o

Now I know what to change for the next round of updates.  However, it still does not explain why I'm getting about a 10% failure rate more than 24 hours past the deadline.  And now, we're more than 72 hours past the deadline and we're down to about 5% failure rate.  Checking through the logs, only a fraction of those failures are on machines where focus assist was listed as I mentioned previously.
#33
Lee
The user deferred the installation from the manage conflicting process options you have set. You can modify those in the publisher, here is the link to the documentation: https://patchmypc.com/manage-conflicting-processes-when-updating-third-party-applications
#34
I did not change any security settings of windows.

It's not a problem with Task Scheduler permission because when i run the Task Scheduler with the option "Task Visibility: Visible", PMPC works just fine, it's only with the option silent, it does not work.

I have a virtual machine with windows 11 pro on beta prerelease and same happens.

As far as i understand via the logs, the unique difference is the /silent is switch to /auto. I guess /silent is broken for some reason on both my systems.
#35
Have you changed any security settings of Windows or are you running an otherwise manipulated Windows release?
It seems that the scheduled task has not the same rights as the interactive process.
#36
Hello,

I've recently started seeing an uptick in software update failures.  After closing inspection, I noticed that:
User in session 1 [xxxxxx] has exited with command: Notification cancelled (Focus Assist enabled)
User has blocked the update installation process (A conflicting process is still running).
End of Script Runner. Exit code is: 1602


Searching this forum and scowering the interwebs, I'm not finding much in the way of whitelisting SCNotification with Focus Assist/Quiet Hours.

I did come across this command line though:
<CommandLine>/MainFile=KeePass-1.40-Setup.exeÿ"/MainArg=/VERYSILENT /NOCLOSEAPPLICATIONS /NORESTARTAPPLICATIONS /NORESTART /SP- /SUPPRESSMSGBOXES"ÿ/BlockingProcessPolicy=Notifyÿ/UserNotificationTimeout=120ÿ/PreventConflictingProcessRestartÿ/NotificationPolicy=AutoCloseÿ/FocusAssistPolicy=DiscardNotificationÿ"/ApplicationName=KeePass v1 - EXE Install"ÿ/ApplicationID=2e630e69-0b39-4b2b-a6c0-3cc3bf8b551bÿ/KillProcessList=KeePass.exeÿ/ShortcutFileName=KeePassÿ/LoggingSwitch=/LOG={path}ÿ/PrefixInstallLogÿ/LoggingPath=C:\windows\ccm\logs\PatchMyPCInstallLogsÿ/LogRetentionDays=28</CommandLine>

Any help will be greatly appreciated.
#37
I am running with a Scheduler, on Task Scheduler, the schedule stays running forever.
I have attached images of my settings from Options and Scheduler from Patch My PC.

If i run Patch My PC mannually, it works fine.
#38
See the attached images for my settings of the scheduler and application.
How are you running PMPC, scheduled through PMPC (like I do), manually or with a custom script?
#39
Ok, so it's not a problem with the application, probably something on my PC. What troubleshooting can i do to find the cause and a solution?
#40
I had the same problem as I tried to update manualy. If you click on download the latest ESR version, it downloads the 91.x, not 102.x . So I think it's a problem of mozilla. You still can donwload the 102.x, but you must search for it specificaly.