Author Topic: Dell Command Update 4.2.0 not installable with DCU 3.0 or lower  (Read 462 times)

Offline MTREICHLER

  • Newbie
  • *
  • Posts: 13
    • View Profile
PatchMyPC with WSUS

DCU 4.2.0 has installable rule where DCU has to be 3.0 or higher to install.  Do we know why the 3.0 or greater limitation exists?  I could adjust the rule to upgrade legacy versions, but rather not if known issues with legacy upgrades.

Somewhat related there are 2 version of DCU.  Classic & UWP DCU 4.2.0 only installs on Classic.  Any plans for UWP DCU update?

Thanks,
 
« Last Edit: June 10, 2021, 01:11:43 PM by MTREICHLER »

Offline Cody Mathis

  • Administrator
  • Jr. Member
  • *****
  • Posts: 84
    • View Profile
Re: Dell Command Update 4.2.0 not installable with DCU 3.0 or lower
« Reply #1 on: June 10, 2021, 11:17:27 AM »
Pre-3.0 is effectively a different app and is not an 'update' but rather an 'upgrade' which would require an uninstall of the old and install of the new. This is why we have this limitation in place. Our updates must support a clean update from a previous version.

Regarding UWP applications, this is not something that is currently on our roadmap.