• Welcome to Support Forum: Get Support for Patch My PC Products and Services.
 

Block Visual C++ 2015-2019 when Visual Visual C++ 2015-2022 is selected

Started by GeoSimos, September 27, 2022, 08:32:10 AM

Previous topic - Next topic

GeoSimos

Hello PMPC Team,

As always, thank you for your great product and support.

I have both runtimes selected (for both architectures) in the ConfigMgr apps list, their updates are also served, the issue I'm facing is that when Visual Visual C++ 2015-2022 runtime is installed and subsequently Visual C++ 2015-2019 update tries to install, it fails because the 2015-2022 version is newer and supersedes it.
I would like to propose the following:
1) The detection rules of 2015-2019 should detect the newer version(s) and skip the installation for a full app or an update.
2) In the PMPC GUI, there must be a blocking function that grays out and deselects (if selected) the older version if a newer is superseding it (for the 2015-xxxx ones). Also a message to remove the old application would be nice.

Do these proposals make sense to you?
Are the above feasible?

With regards,
George Simos

Andrew Jimenez (Patch My PC)

Hi George,.

Thank you for these suggestions, I honestly think the solution here will be to replace Visual C++ 2015-2019 with Visual C++ 2015-2022. I am going to do some research on this and see if that will be an acceptable solution.