Author Topic: Google Chrome 58 Not Detecting  (Read 5601 times)

Offline JEiben812

  • Newbie
  • *
  • Posts: 6
    • View Profile
Google Chrome 58 Not Detecting
« on: May 18, 2017, 09:49:02 AM »
My SCCM clients are not detecting any of the Google Chrome 58.x.x.x updates.  I see that Installable Rules have changed since the 57.x.x.x updates.  We currently only deploy the x86 version.

There are several "AND" clauses which all have references to one of the following registry strings:

Quote
Registry String 'HKLM\SOFTWARE\WOW6432Node\Google\Update\ClientState\{8A69D345-D564-463C-AFF1-A69D9E530F96}\ap' = 'x86-stable'.
Registry String 'HKLM\SOFTWARE\Google\Update\ClientState\{8A69D345-D564-463C-AFF1-A69D9E530F96}\ap' = 'x86-stable'.

The "ap" registry value does not exist in the registry of any of the clients I have checked.
« Last Edit: May 18, 2017, 09:51:54 AM by JEiben812 »

Offline Justin Chalfant

  • Patch My PC Support
  • Administrator
  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
    • Patch My PC Support
Re: Google Chrome 58 Not Detecting
« Reply #1 on: May 18, 2017, 10:40:43 AM »
Did they deploy Chrome using the MSI?

Offline JEiben812

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Google Chrome 58 Not Detecting
« Reply #2 on: May 18, 2017, 11:14:04 AM »
Yes, the initial install uses the "googlechromestandaloneenterprise.msi" version 55.0.2883.87.  All previous SCUP updates through 57.0.2987.98 detected and installed as expected.

As a test, I rolled a machine back to the 55.0.2883.87 install, and reran detection in SCCM.  57.0.2987.98 detects, but 58.0.3029.96 does not.  Even after installing 57.0.2987.98, 58.0.3029.96 still does not detect.


Offline Justin Chalfant

  • Patch My PC Support
  • Administrator
  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
    • Patch My PC Support
Re: Google Chrome 58 Not Detecting
« Reply #3 on: May 22, 2017, 08:35:16 AM »
Can you export the "'HKLM\SOFTWARE\WOW6432Node\Google" and "'HKLM\SOFTWARE\Google" and email it via ZIP file using the technical support form?

Offline JEiben812

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Google Chrome 58 Not Detecting
« Reply #4 on: May 22, 2017, 10:51:28 AM »
ZIP file sent.  Note that only "HKLM\SOFTWARE\WOW6432Node\Google" is provided as we only use Chrome (x86) on 64-bit OS.

Offline Admin - Omar

  • Administrator
  • Hero Member
  • *****
  • Posts: 1104
    • View Profile
    • Patch My PC
Re: Google Chrome 58 Not Detecting
« Reply #5 on: June 06, 2017, 07:02:41 PM »
It should be fixed in today's catalog update with Chrome 59.0.3071.86, please let us know if there are any problems :) 
« Last Edit: June 07, 2017, 06:21:41 AM by Omar - Admin »

Offline Justin Chalfant

  • Patch My PC Support
  • Administrator
  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
    • Patch My PC Support
Re: Google Chrome 58 Not Detecting
« Reply #6 on: June 07, 2017, 03:47:38 PM »
Just wanted to follow up here. You still may actually see an issue with the update not showing as applicable. We added a rule to detect when the AP value = multi-version to map to Chrome x86. We are will working on a rules to update Chrome x86 if the AP value doesn't exist at all. We will either revise the Chrome update from yesterday or add it to the next update.

Justin

Offline JEiben812

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Google Chrome 58 Not Detecting
« Reply #7 on: June 30, 2017, 10:54:45 AM »
It is working now.  Thank you.