• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

Java - Disable Auto-update not working

Started by Blanzeros, September 12, 2023, 09:02:15 AM

Previous topic - Next topic


EDIT: resolved after publishing latest version; potential human error

After pushing a new version of Java to a collection (using the created application and supersedence), users are reporting pop-ups for the latest version are available.

I've checked the options on the application tab for PMP and 'Disable self updater' is enabled as is the default option I believe, however I can't see it working in the scriptrunner.log

What am I missing?

Spencer (Patch My PC)

Hey Blanzeros,

Thanks for reaching out to the forum! When you enabled the option to "Disable Built-In Updater" did you run a publishing service sync to apply that setting to the application?

You can do this under the Sync Schedule tab in the Publisher by clicking on Run Publishing Sync Service.

If that doesn't work, please send me the following log files - [email protected]:



Thanks Spencer.

The option is enabled by default so I didn't manually run a publishing sync. The issue seems to have been resolved with the latest version though. It's possible this was caused by some internal issues here.

Thanks anyway