• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

[Resolved] App doesn't update - No Error

Started by Remotepall, June 29, 2022, 05:42:33 PM

Previous topic - Next topic



Having an issue where app isn't actually performing any updates.
- Start the app, Scan for updates.
- Shows 6 updates pending.
- Click perform update
- Right side of screen clears as normal as if it is about to start the download and update process.
Nothing happens. Logfile isn't showing any error, and I get the same result from a /s at command (I assume, logfile has same result.) Personally looks like a connection issue or the app trying to reach out but being blocked, but I have no log files that indicate that.

- Delete and redownload.
- Moved app out of User Dir.
- Uninstalled AV.
- Disabled Defender.
- Disabled ipv6

I haven't been able to test using a tether to phone to see if it is the network; however my laptop on the same network runs the program fine. Both PC's are running Win11, however the desktop is Win Enterprise and the laptop is Pro. I have had a look around and I couldn't see anything that mentioned enterprise edition not being supported.

Any assist is welcomed.


Gif of display



I have the exact same issue. Windows 11 user, AV is F-secure. Performed the exact same steps with the same results.


Just marking this thread as closed. After going through a couple of other threads I saw that PMPC had some Reg entries for options and settings. After going into HKEY_LOCAL_MACHINE\SOFTWARE\Patch My PC\Options I saw that there was an option for IT-Pro-Cache and the value was something like: E://itprocache. I deleted this entry and the program behaved correctly on next launch.