• Welcome to Support Forum: Get Support for Patch My PC Products and Services.

Changes to Conflicting Processes not saving

Started by rlgura, February 02, 2024, 01:41:53 PM

Previous topic - Next topic


PMPC Publisher version

I'm trying to switch MS Edge WebView2 Runtime to "Skip installation when conflicting processes are in use" because it really doesn't play nice with the new Teams client (and I also added ms-teams.exe to the process list), but when I click Save and Close and check the update again, my changes are not saved. I tried with a couple other apps and same result. Also verified in my QA environment.
I've done this previously with Zoom Desktop (didn't want users closing their Zoom Phone while on a call) and those changes are still saved.

Spencer (Patch My PC)

Hey there!

Thanks for reaching out to support!

Can you please collection the publisher log bundle and send that over to [email protected] with a descript of the issue/screenshots?

In the General tab of the Publisher, click on the Collect Logs button under Logging Options
Pick a Folder where you want to save the logs to
a ZIP file containing the relevant server-side logs needed for troubleshooting will be created in that location. You can then send that ZIP file over to us.

We'll look through the logs and try to repro this issue in our lab environments!


Spencer Cruz

Spencer (Patch My PC)

Also, if this is an already published package (not a new version of the package) then you'll need to republish it before the new settings will apply.


Let me know if that helps!


It's not even saving in Publisher.
The initial configuration: step1.png
I add the additional process and change policy to skip: step2.png
Hit OK, OK, Save and Close
Re-open Publisher and settings have reverted: step3.png

OK. There's a bug here. Publisher is not picking this up as a change - I have no option to click Apply (only Save and Close). If I make some other change (like pre/post script), I can then click Apply and the changes to Conflicting processes saves.

Spencer (Patch My PC)

Thank you for confirming! We'll for sure want to take a look at the log files!

Please collect and send those logs over to [email protected] and we'll look into this for you! I'm unable to replication this issue in my lab, so the settings file may help us!

Andrew Jimenez (Patch My PC)

Update here. An internal bug has been submitted to the dev team. The following can be used as a workaround:
  • Navigate to the ConfigMgr Apps tab
  • Select then de-select any product (this will light up the apply button)
  • Make your changes to Manage Conflicting Processes
  • Click Apply
  • Save and Close, then check that the settings adjustment was saved.