• Welcome to Support Forum: Get Support for Patch My PC Products and Services.
 
Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - Andrew Jimenez (Patch My PC)

#1
Hello Mark,

I believe it will keep the customizations that are in place when updating.
#2
Hi George,.

Thank you for these suggestions, I honestly think the solution here will be to replace Visual C++ 2015-2019 with Visual C++ 2015-2022. I am going to do some research on this and see if that will be an acceptable solution.
#3
Hello,

We have not tried this ourselves, have you tried specifying both the Language to install as well as the transform?
https://www.adobe.com/devnet-docs/acrobatetk/tools/AdminGuide/language.html#pre-deployment-configuration
#4
Hello,

This app is definitely troublesome with all of the apps that must be closed to update it. We are actually adding a few other apps that we have found block it's installation as well. My only suggestion here is to use the "Manage Conflicting Processes" notifications to let your users know that they need to close the app in order for it to update.

Another workaround if you are on ConfigMgr is, you can deploy the app to update existing installs, and set it to run if no users are logged on.
#5
Copying from another thread:

The version of Firefox ESR in our catalog at this time is still up-to-date, it should contain the same security fixes that were added in version 102. The next ESR release will be 102,

The current version of Firefox ESR in our catalog is 91.13 released on 8/23/2022
https://www.mozilla.org/en-US/firefox/91.13.0/releasenotes/
Security Vulnerabilities fixed in Firefox ESR 91.13 — Mozilla

The current 102 release of ESR is 102.2 also released on 8/23/2022
Security Vulnerabilities fixed in Firefox ESR 102.2 — Mozilla

Patch My PC will be moving to Firefox ESR 102 upon the release of ESR 102.3 on 9/20/2022

I compared the list and 102 does indeed have 2 extra fixes over 91.13, however the only High criticality vulnerability that is fixed in 102 that is not fixed in 91.13  (CVE-2022-38477) is fixing a bug that only existed in the 102 and greater branch. The other, low impact CVE does not mention the versions affected.

Firefox keeps 2 versions of ESR alive for 3 point releases when they have a major ESR release, the older version is more stable, and this gives Mozilla time to stabilize the newer ESR release. Mozilla still provides the same vulnerability patches to both versions while they are both supported. Patch My PC has decided to stick with the more stable ESR, as we assume customers that choose the ESR release are doing so for the stability benefits.

We do not intend to add the newer ESR release at this time as it would significantly increase the number of Firefox updates in our catalog, it would also introduce complicated applicability considerations.
#6
Hello,

Unfortunately, Microsoft has expired the ConfigMgr Client Toolkit. It is currently being decommissioned in our catalog for full removal. https://patchmypc.com/how-products-are-handled-at-end-of-life-eol-or-become-incompatible
#7
Hello,

Unfortunately, there isn't an "easy" way to check these rules. Most of our rules are much less complicated than this (in fact, we do not utilize WMI based rules at all because they are slow). Sorry we can't be of more help!
#8
Hi Matthias,

You should be able to right click the app in the Patch My PC interface, and choose to "Republish" the app during the next sync schedule, then run a sync.
#9
Hi Eddie,

We do not change the default behavior of the updates from the vendor. Are you using right click options to close the applications before patching?

I am testing this app to confirm this behavior, but in general we test to ensure that app upgrades do not force a reboot, we do not test if an update closes an app upon updating.
#10
Eddie is correct here. This question comes up quite a bit, so I am going to include my reply from a recent email:

The version of Firefox ESR in our catalog at this time is still up-to-date, it should contain the same security fixes that were added in version 102. The next ESR release will be 102,

The current version of Firefox ESR in our catalog is 91.13 released on 8/23/2022
https://www.mozilla.org/en-US/firefox/91.13.0/releasenotes/
Security Vulnerabilities fixed in Firefox ESR 91.13 — Mozilla

The current 102 release of ESR is 102.2 also released on 8/23/2022
Security Vulnerabilities fixed in Firefox ESR 102.2 — Mozilla

Patch My PC will be moving to Firefox ESR 102 upon the release of ESR 102.3 on 9/20/2022

I compared the list and 102 does indeed have 2 extra fixes over 91.13, however the only High criticality vulnerability that is fixed in 102 that is not fixed in 91.13  (CVE-2022-38477) is fixing a bug that only existed in the 102 and greater branch. The other, low impact CVE does not mention the versions affected.

Firefox keeps 2 versions of ESR alive for 3 point releases when they have a major ESR release, the older version is more stable, and this gives Mozilla time to stabilize the newer ESR release. Mozilla still provides the same vulnerability patches to both versions while they are both supported. Patch My PC has decided to stick with the more stable ESR, as we assume customers that choose the ESR release are doing so for the stability benefits.

We do not intend to add the newer ESR release at this time as it would significantly increase the number of Firefox updates in our catalog, it would also introduce complicated applicability considerations.
#11
If you have the Patch My PC Publisher installed, and have put the installers in the local content repository, you will want to also ensure that you have the option to "Check the local content repository for content files before attempting to download content files from the internet." enabled in order for the Publisher to pick up those local content downloads.

https://patchmypc.com/local-content-repository-for-licensed-applications-that-require-manual-download#topic5
#13
Hello,

Because this update depends on Cisco AnyConnect Secure Mobility Client, we have that update as a prerequisite for this update. Once the newer (matching) mobility client is installed, this update will show as applicable.
#14
Yes, the existing Adobe x64 installers will fail with the error 150201. This is an issue with the installer unfortunately and there isn't much we can do about it.

You can get the app to install outside of OSD by doing the following: set the user experience option on the deployment type to "Allow users to view and interact with the program installation".
#15
Oh wow! We actually have had a few customers with this issue and have been unable to determine a resolution. I'll pass this info on to our other customers and see if it fixes it for them as well.

Thanks so much for posting the fix!